Пожалуйста, войдите или зарегистрируйтесь.

Автор Тема: Если не работают приложения Metro (ModernUI) в Windows 8 SL (и других)  (Прочитано 26152 раз)

Dimonira

  • Старший сержант
  • *****
  • Reputation Power: 3744
  • Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!Dimonira вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 37

Столкнулся с проблемой, выражающейся в неработоспособности многих приложений Metro (ModernUI) в предустановленной Windows 8 SL на MSI GT70-0ND.
Например, не работали Skype, Ebay, и др. Все они не работали одинаково: при запуске приложения открывался начальный экран заставки (в полноэкранном режиме), а потом всё это тут же сворачивалось и возникал экран Пуск. Причём приложения (точнее, начальные экраны от них) висели на выпадающем слева списке задач, но при попытке ткнуться на них они тут же сворачивались.
Пробовал запускать простейшее приложение (типа Hello World), сделанное в Visual Studio 2012. Оно тоже не запускается! (Лицензия разработчика имеется).
Студия выдаёт окно с сообщением:
Цитировать
Не удалось активировать приложение ... из магазина Windows. Запрос на активацию завершился неудачей с ошибкой "Приложение не запустилось"
Посмотрел системный лог. В логе приложений вижу типа такого:
Цитировать
Сбой активации приложения c32f65cf-252c-4c50-863d-0441cbc6ee5b_5096cyatp5wte!App. Ошибка: Приложение не запустилось.. Дополнительные сведения см. в журнале Microsoft-Windows-TWinUI/Operational.
А в логе системы это:
Цитировать
Регистрация сервера App DCOM не выполнена за отведенное время ожидания.
Два раза я переустанавливал Windows с нуля. В последний раз я уже ничего кроме системы не ставил, только вышеназванные приложения из магазина - всё равно они не работали.
Стало понятно, что дело в ущербности прединсталлированной системы.
Решение нашёл на англоязычном форуме поддержки: http://forum-en.msi.com/index.php?topic=163928.0
Скачал и запустил AppsDiagnostic.diagcab (http://go.microsoft.com/fwlink/?LinkId=268423), выбрал Windows Store Apps, нажал "далее", он нашёл пару каких-то проблем (какие-то права где-то отсутствовали, что-то с сервисом BITS) и предложил перезагрузиться. После перезагрузки метро поехало!!!
Записан

denim025

  • «Fidelitas et virtus»
  • Лейтенант
  • **
  • Reputation Power: 207
  • denim025 имеет некоторый авторитет.denim025 имеет некоторый авторитет.
  • Оффлайн Оффлайн
  • Сообщений: 187

Отличное решение, только сегодня заметил что некоторые приложения не запускались, а просто сворачивались. Решение супер спасибо помог, если бы не статья переустановка была бы обеспеченна)) Я просто на моноблоке запускал свои приложени, а тут на буке понадобились. Еще раз спасибо. :lookandok:
Записан
MSI GT70 ONC 630RU

MalkolmUT

  • Ефрейтор
  • **
  • Reputation Power: 1
  • MalkolmUT пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 5

Спасибо! Очень помогли!
Записан