Пожалуйста, войдите или зарегистрируйтесь.

Автор Тема: Настройка BIOS материнской платы MSI MAG B550 Tomahawk при работе с NVMe SSD М 2  (Прочитано 782 раз)

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Здравствуйте!!!
У меня вопрос к знатокам и опытным юзерам, подскажите что нужно делать, что я сделал не так?
Собрал я комп на основе материнской платы MSI MAG B550 Tomahawk и процессора AMD Ryzen 5 3600.
Установил в плату два SSD. Первый – SSD M.2 2280 Samsung 980 PRO 250 GB (MZ-V8P250BW) – в слот М 2 Gen 4, второй SSD M.2 2280 500GB Kingston (SKC2500M8/500G) – в слот М 2 Gen 3.
   Винду (10) собрался устанавливать на первый SSD – Samsung.
Так вот, после того как система была собрана, я вошел в БИОС платы (Click BIOS 5) который работал в режиме UEFI, то обнаружил, что моих два SSD диска не отображаются в режиме БИОСа «boot mode select» меню (!?), также эти диски не были отражены в «boot priorities» (!?). То есть, выбрать один из них для установки венды с загрузочной флешки по приоритетам, а также через F11 не получалось, в последнем случае эти диски не были доступны. При этом на плате высвечивалась ошибка «BOOT - indicates the booting device is not detected or fail», хотя диски БИОС видел, он их показывал в разделе «storege» режим работы EZ Mode.
При запуске через F11 с флешки (при этом кроме флешки другие диски не отображались), на экране вылетали какие-то артефакты, как при поломке видеокарты и все!!! Приходилось перезагружать комп и через delete снова входить в БИОС для дальнейших «танцев с бубном».
Закончились эксперименты тем, что я перешёл в режим boot mode select – LEGACY + UEFI и, о чудо, нашел свои SSDшки в одном из подменю …., при этом смог загрузится с загрузочной флешки через F11 (теперь SSD оба уже отображались вместе с флешкой … ) и установить таки Винду на  SSD Samsung 980 PRO (!!!!). Далее этот диск появился в меню БИОСа, то ест его стало возможным в меню «boot order priorities», назначить в «boot option #1», дабы с него стартовала Винда при включении системы. При этом второй SSD диск Kingston (SKC2500M8/500G) для этого доступен не был и после установки Винды в ней хоть и был виден, но в проводнике не отображался пока его я не инициализировал через диск менеджер в той же Винде … .
В дальнейшем, при последующей настройке компа, при попытке переключить БИОС исключительно в режим UEFI, система не стартовала и опять приходилось «танцевать с бубном».
Также при попытки активизировать технологию AMD Smart Access Memory, которую, учитывая железо (Ryzen 5 3600 + Radeon RX 6600 XT) и программную часть мой копм должен тянуть, при условии, что его БИОС будет работать в режиме UEFI, при включении в настройках БИОСа, который работал в режиме «boot mode select – LEGACY + UEFI»,  функций Above 4G Decoding и Re-Size BAR Suppor, сохранении этих параметров настройки и перезагрузке, очевидно, БИОС автоматом уходил в режим UEFI и после перезапуска системы он ее уже не запускал, на экране снова артефакты и ВСЕ (!) перезагрузка не помогала … Пришлось отключать комп, сбрасывать CMOS, то есть настройки БИОСА и заново настраивать в его режиме LEGACY + UEFI. Тогда система опять стартовала.
В общем вопрос очевиден, я «чайник», и скорее всего, что-то не понимаю, что именно я не понимая я тоже не понимаю. Система работает, но как ее заставить работать в режиме БИОСа – UEFI, ведь эта плата вроде как поддерживает работу с NVMe SSD и т.п.
Как заставить БИОС отображать установленные NVMe SSD «корректно или типа того» в меню «boot order priorities» и «boot priorities» и вообще работать с ними в режиме БИОСА UEFI??? Подскажите пожалуйста, буду очень благодарен!!!   
Записан
Marked as best answer by st-sled 20 Сентябрь 21, 19:06:46

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

Диски и не должны были видеться - они пустые.
Загрузились с инсталляции флешки ( нормальной винды а не левой инсталляции) , подбросили драйвера. Указали на какой ставить. Все. Если что то в BIOS после инсталляции винды ставить первым в загрузку wondows boot manager/
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Я по поводу Вашего ответа: "Диски и не должны были видеться - они пустые.
Загрузились с инсталляции флешки ( нормальной Винды а не левой инсталляции) , подбросили драйвера. Указали на какой ставить. Все. Если что то в BIOS после инсталляции Винды ставить первым в загрузку wondows boot manager/"
Хочу уточнить, я ставил с флешки нормальную Винду ..., лицензионный ключ и все такое ..., у меня все установилось. Но вопрос в том, что оба SSD после установки (ну и до нее) в БИОСе работают только в режиме «boot mode select – LEGACY + UEFI»,  если просто в UEFI, то комп не запустится вообще, а этом режиме, что пустые, что "полные" SSD c Виндой и все такое, в БИОСе их нет в boot priorities ..., то есть  SSD не работает исключительно в UEFI, а без ее работы, то есть UEFI,  не нельзя использовать  технологию AMD Smart Access Memory, т.к. для ее задействования БЫОС должен быть в UEFI, а с ним (UEFI) не запускается Винда (комп) установленная на SSD то есть с этого NVMe SSD. Вопрос был как заставить работать NVMe SSD в  UEFI ??????
Записан

dmitryprauss

  • Сержант
  • ****
  • Reputation Power: 21
  • dmitryprauss пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 17

Фишка в чём, если Вы загрузочную флешку делали сами (например через rufus) то, там есть выбор uefi или legasy и соответственного раздела GPT и MBR и там же fat или ntfs. Нужно перезаписать загрузочную флешку.
Если стандартной утилитой с сайта майкрософт, то, она тоже не всегда в правильном формате пишет и по итогу на какие-то системы ставиться спокойно, а на какие-то - танцы с бубном.
Записан

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

Еще раз.  Никаких проблем нет . В BIOS выставили UEFI ,  сохранили, перегрузились, нажали F11  выбрали UEFI ( загрузочную флешку) , далле по плану. 
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Я флешку делал используя MediaCreationTool21H1, то есть с официального сaйта Microsoft и Винада установилась, правда только когда я включил в БИОСе режим  «boot mode select – LEGACY + UEFI». Просто в UEFI - не хотела, очевидно не видила SSD (?).  Винда стала все ок, но  если в настройках БИОСА сейчас поставить «boot mode select – UEFI», то после сохраняя данного параметра она не запустится!!! Учитывая ответы выше. Что мне нужно сделать чтобы БИОС в  режиме  «boot mode select – UEFI» увидел SSD и с него загружался и все такое: 1) Переустановить Винду, установив перед перестановкой  «boot mode select – UEFI», но если в этом режиме (UEFI) БИОС не видит SSD (?), что и было до этого (?), то тогда как .... 2) Я не правильно создал загрузочную флешку, гипотетически,  хотя делал все как обычно, ну точнее софтом на официальном сайте и по инструкции, и в этом проблема, хотя при первичной установки именно флешку БИОС и видел, а SSD нет, ну не считая раздела «storege» тут они SSD оба были. Ок как проверить правильную ли я создал флешку ....

P.S.: ребята, не обижайтесь. ценю Ваши ответы и желание помочь, но ... толи мы на разный языках говорит, толи ... я не знаю, что. Я вроде бы пытался объяснить суть проблемы, а получаю ответ о том как установить Винду - она установлена, тут, все !!!! Все работает!!! Но только в режиме настройки «boot mode select – LEGACY + UEFI», а в «boot mode select – UEFI» нет, и как я понял в последнем случае БИОС не видит SSD как устройства доступне для чтения с них и загрузки. Или я не прав (!?) Кто действительно понял суть проблемы  в этом разбирается скажите просто типа так: "Ты сделал вот это не правильно, по этому это работает вот так вот или неправильно,  а нужно сделать следующее по пунктам 1 ..2.. 3... 4.... так перепроверить так настроить и тому подобное ". А так я вижу рекомендации как установить Винду. Повторюсь, я ее установил, может я это сделал не правильно - отпишитесь как проверить и что исправить. Не сердитесь, заранее благодарен за понимание ну и дельный совет ))))
« Последнее редактирование: 20 Сентябрь 21, 16:34:39 от st-sled »
Записан

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

У вас винда установлена в режиме Legacy - и тут все. То есть про   AMD Smart Access Memory забыть и некоторые другие фичи.
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

То есть, переустановить .... я так понимаю (?), ну попытаться по схеме: "В BIOS выставили UEFI ,  сохранили, перегрузились, нажали F11  выбрали UEFI ( загрузочную флешку) , далее по плану. "
Записан

dmitryprauss

  • Сержант
  • ****
  • Reputation Power: 21
  • dmitryprauss пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 17

То есть, переустановить .... я так понимаю (?), ну попытаться по схеме: "В BIOS выставили UEFI ,  сохранили, перегрузились, нажали F11  выбрали UEFI ( загрузочную флешку) , далее по плану. "

Прочитайте про GPT и MBR. В каком применяется под legasy, а в каком под uefi. Именно по этому, Вы, в одном режиме видите винду и диски, а в другом - нет.
Записан

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Докладываю всем кому интересно чем закончится ))))
Пробовал решить проблему переустановкой Винды, заново создал загрузочную флешку и все такое, а дальше шел предложенным "маршрутом", то есть :  "В BIOS выставили UEFI ,  сохранили, перегрузились, нажали F11  выбрали UEFI ( загрузочную флешку) , далее по плану ", НО нЭЭтттт, ничего не вышло, все тоже самое. И я предполагаю, что, как уже отмечено выше, эта проблема связана со структурой NVMe SSD при установке UEFI, у меня на этих SSD  стиль MBR, и, я так предполагаю, что  UEFI их просто не видит, а посему и ничего с флешки никуда загрузить не может (!?), а BIOS их видит и тогда все ОК. И по этой причине Винда становится только если выставить в настройках «boot mode select – LEGACY + UEFI» (!!!). Следовательно, нужно поменять (попробовать) стиль разделов NVMe SSD с MBR на GPT (?!?). На самом деле это последнее возможное здравое объяснение проблеми и путь ее решения!!! И да, автор: dmitryprauss, Вы наверно таки правы и Ваш комент, по моему мнению конечно, тут самый адекватный (!). Ну как попробую это решение (нужно немного времени свободного, а его пока нет), так сразу доложу )))) 

Записан

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

У вас флешка UEFI? Инсталятору пофигу как разбит у вас диск  так как он сам может его переразбить используя diskpart/ А вот UEFI или Legacy инсталляция вот тут 2 огромные разницы. SSD можно затереть используя встроенную утилиту в BIOS   Secure Erase+
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Отвечу так.
Флешка (загрузочная) создана на  утилите Media Creation Tool и в boot menu  отображается дважды, в т.ч. и с пометкой "UEFI", т.е. загрузочная флешка, совместима и с обычным BIOS, и с UEFI.
Винда устанавливалась на новый - неинициализированный SSD (!!!). При установке на неинициализированный диск, так как я загружался в режиме  «boot mode select – LEGACY + UEFI»,   Винда по умолчанию делает его стиль MBR (я этот момент провтыкал, скажем так ...), а второй диск, который так же не был виден в UEFI, я уже сам инициализировал в Винде после ее установки и определил его стиль как MBR (!). По этой причине (предположительно) его не видел UEFI - он же не загрузочний (!) .
Ну как-то так.
Да это уже даже не "танцы с бубном", а я бы сказал уже "гадание на кофейной гуще", но с точки зрения теории данная ситуация вполне объяснима. Эксперимент покажет так ли это. Нужно, к примеру второй диск сделать (конвертировать) со стилем GPT и тогда будет видно .... .     
« Последнее редактирование: 21 Сентябрь 21, 12:06:19 от st-sled »
Записан

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

Честно ? Создаете сами себе проблемы . Никаких танцев нет когда все сделано правильно. Спрашиваю последний раз - вы при выборе загрузки указали UEFI флешку ? Обратите внимание что в boot menu флешки две.
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Да, конечно, я, может неоднозначно выразился, но да я стартовал именно так, ДА - при выборе загрузки указал UEFI флешку, когда начинается загрузка с нее, при настройке   «boot mode select –  UEFI», то комп зависает, черный экран, а в нижней его части корричнево-белые артефакты, очевидно это так кромсает логотип ... (?), а при настройке  «boot mode select – LEGACY + UEFI» и при выборе загрузки с той же UEFI флешки, загрузка идет штатно ... , но при последующей перенастройке в режим «boot mode select –  UEFI» - система не стартует, т.к. в «boot priorities» невозможно установить SSD на который установилась Винда, да его в этом режиме и не видно (!), а вот в режиме «boot mode select – LEGACY + UEFI» - видно, но второй нет (!). Оба этих NVMe SSD со стилем разделов MBR (!), что может быть проблемой (!?).
« Последнее редактирование: 21 Сентябрь 21, 13:27:09 от st-sled »
Записан

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Ребята, для тех кому еще интересно чем закончится )))
Попробовал я при помощи стороннего софта изменить на загрузочном NVMe SSD диске (С:) с Виндой его стиль разделов MBR на стиль GPT с сохранением на диске данных, в т.ч. и установленной на него Винды, дабы все потом на этом же диске заново не переустанавливать и все такое .... Но, в процессе работы программа дала сбой (во б....) и Винда благополучно слетела (ха-ха-ха, подумал я)  и я через биос встроенной там утилитой затер этот диск (нахрен к чертям собачим) и приготовился к новому экспиренсу с повторной установкой Винды. Настроив все "как книжка пишет" для работыUEFI я начав процесс  .... и, как неожиданно, да (!!!), опять "танцы с бубном" ))))   Выставив в настройках загрузки:  «boot mode select –  UEFI» и начав загрузку с UEFI флешки, получил ровным счетом - ничего! То есть, при старте процесса, он прерывается, так и не начавшись по сути, и на черном екране в верхней или нижней части (как когда, я так понял все зависит от того в какую руку бубен возьмешь ))) )  появляюся бело-корричневие артефакты (это цвета рисунка заставки на экране ...) и ФСЁ комп виснет, дальше перезагрузка в ручную. При любых попытках и вариантах настройки с  загрузки Винды с UEFI флешки результат аналогичный, разница лишь в том, в каком месте экрана выскакивают артефакти (внизу или сверху ))) ).  Устав от  "танцев с бубном" и "гадании на кофейной гуще", я настроил систему в режим «boot mode select – LEGACY + UEFI» и загрузил Винду с той же флешки, но не в режиме  UEFI, а как для обычного BIOS и .... (при создании загрузочной флешки через MediaCreationTool21H1 мы получаем флешку которую можно использовать в двух сценариях и LEGACY и UEFI ) О чудо, процесс загрузки стартовал, Винда без приключений установилась, а диск (С:) получил при разметке по прежнему  (автоматически) стиль разделов MBR (!?). И все !!!!
Из вышеописанного, гипотетически (опять таки) можно предположить что проблема связана (может быть, а может и нет) и с самой Виндой (10) или создаваемой нею загрузочной флешкою, и с самим  BIOS UEFI, и с дровами на NVMe SSD М2 Gen 4.0 ... как вообще так (может быть) и в частности на Samsung 980 PRO 250 GB (MZ-V8P250BW). В общем кто его знает ()?, но "собака след не берет".
Лично я устал от этого всего и решил, что пока остановлюсь на достигнутом (!!!!). А там новая прошивка биоса (может) что-то изменит, или 11 Винда лучше станет, или загрузочную флешку создам при помощи сторонних приложений - будет видно (!?)
Может кто-то сталкивался с подобной ерундой на такой же материнке (ну или другой на В550), делитесь опытом!  Буду благодарен!     
Записан

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Итак, ребятки, я нашел таки решение проблемы ))))))))) !!!!!
Все оказалась очень просто, но перед тем как рассказать все подробно, хотелось бы узнать у тех, кто посетил мой пост, как вы думаете, где "собака порылась", в чем таки действительно была проблема?
А пока не буду раскрывать карты и спойлерить, пусть сохранится интрига!   
Чуть позже все опишу! А пока жду ваши версии ))) 
Записан

Дмитрий Кучинский

  • Модератор
  • *****
  • Reputation Power: 19957
  • Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!Дмитрий Кучинский вызывает восторг!
  • Оффлайн Оффлайн
  • Сообщений: 14,139
  • Очень злой модератор

Есть подозрение на память. Или кривая флешка.
Записан
Добро пожаловать на форумы пользователей продукции MSI! Для официальной поддержки, пожалуйста, свяжитесь с нами напрямую - Контакты

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Внимание, а теперь правильный ответ!!!
Теперь все по порядку и подробно, пост будет длинный, готовьте чай и печеньки )))))
Проблема, как оказалась, заключается в том, что при установке Винды в режим «boot mode select –  UEFI», я устанавливал загрузочную флешку в порт USB версии 3.0, и ничего хорошего не происходило. Как только я установил ее в порт USB версии 2.0 (их всего два и они на задней панели …) система как-то призадумалась, потом на экран выдало заставку з изображением логотипа «MAG» в коричнево-белых цветах, этот логотип некоторое время висел на экране, а потом, о чудо, в нижней его части появилась анимация прогресса старта Винды (маленькие белые сферки которые водят хоровод), ну а потом уже стандартное меню установки операционной системы. Надо отметить, что при этом, в отличии от установки в режиме «boot mode select – LEGACY + UEFI», разрешение картинки на экране монитора сразу было Full HD.
Точнее проблема, скорее всего, с софтом – драйверах к USB портам, возможно в самой Винде, т.е. ее именно в версии для установки в режиме UEFI, а может в придачу и в самом ПО для BIOS/UEFI от MSI, точно непонятно, но факт остается фактом.
Такой вывод я сделал так как заметил, что при установки загрузочной флешки версии USB 2.0 с Виндой для загрузки из-под UEFI в порт USB версии 3.0, эту флешку (USB 2.0) UEFI просто не могла или не хотела читать (?). Результат – сбой, черный экран с полосами внизу коричнево-белого цвета. И все «финита ля комедия»!!!
При этом, в качестве эксперимента, использовались разные флэш-накопители (разные производители, разный объем, разный способ создание загрузочного файла и т.п.), но результат был один и тот же, ну то есть, его не было, пока использовался порт USB версии 3.0. Нужно сказать, что на самом корпусе компа их было 2 +1, версии 3.1 (тейп С), с задней панели через удлинитель я еще один подключил, а в 1 порт USB версии 2.0 «воткнул» мышь, второй (он же для обновления биоса) был свободен.
Таким образом, вероятно, проблема не в самих флешках! Скорее всего виною всему софт, ну или мне просто попалась бракованная материнка с таким вот глюком (?), кто знает (на форуме так никто и не отписался о подобных проблемах). Но при том всем на МАТЕРИНКЕ из-под обычного BIOSа установка Винды в режиме CSM с той же флешки стартовала без проблем (!?). Странно это все, но ладно.
Кстати, не будет лишним отметить, что с этой проблемой я так же обратился к MSI (в службу поддержки), но особо они ничем и не помогли, хотя, нужно заметить, внимание ко мне оказали достойное, прониклись проблемой, интересовались победил ли я ее (проблему). Мы несколько дней переписывались, но к решению проблемы MSI (служба поддержки) была очень далека, советы были, в основном, банальные, ну ли уместные, но не к этой теме, – типа поменять кабель к монитору ))))), вдруг поможет, или сменить порт подключение на видеокарте … (ну да, это для инсталляции Винды самое оно …).   
Ну и тут было не все так радужно и просто, чествуете интригу (?) – да без «танцев …» все равно не обошлось.
Как только, я обнаружил, что процесс установки стартовал при установки загрузочной флешки в порт USB версии 2.0, я почувствовав себя «победителем», и решил переустановку системы отложить на следующий день. 
Но, на следующий день, – а не тут-то было (ха-ха-ха). Флешку, установленную в порт USB 2.0 на задней панели, UEFI конечно читал ее, но вот загрузка Винды не стартовала, опять сбой, и после красивого логотипа «MAG» в разрешении Full HD я получал – f…..k. Печально да (!?), а так все хорошо начиналось. Я опять перебрал комплект флешек и настроек BIOS/UEFI, и натанцевавшись с бубном от MSI вдоволь, решил уже поглумится со своей материнки и, тупо, поставил в два имеющихся у не порта USB 2.0 по загрузочной флешке в каждый (типа, на те с…ка!!!). При этом, для полного издевательства, я умышлено не указал с какой же из этих флешек UEFI должен стартовать, ну т.е. не выставил приоритет. Такое решения я предпринял специально, предположив, что при прочих равных, учитывая что в режиме «boot mode select –  UEFI», UEFI кроме этих двух дисков других не видит, а они по сути равны между собой в приоритете загрузке и UEFI будет сам «тыкаться» от к одной, то к другой при отказе одной из них или обеих, но по очереди и все такое (ересь конечно, но а вдруг сработает, и чем это хуже совета от MSI о замены шнура к монитору(???)).
Короче, типа «закольцевал» я флешки ну или «зациклил» – так будет наверно правильно на языке программистов )))).
Таким образом, я создал для UEFI бесконечный цикл при условии, если обе загрузочные флешки не мертвы, UEFI будет между ними переключатся бесконечно, ну наверно, а может и нет (!?), пока не выдаст какой-то результат. При этом если одна из этих флешек «истина» (true) – жива и на что то способна, то установка Винды таки запустится, после проверки всех шагов и вариантов запуска самим UEFI (ну я немного прикалываюсь, но суть я думаю понятна). Мы же экспериментально установили, что это (загрузка вообще) возможно при установке загрузочной флешки именно в порт USB версии 2.0.
Так вот, после описанных выше «танцев» и манипуляций UEFI подумал немного, выдав на экран монитора заставку с логотипом «MAG» без глюков в разрешении Full HD … и … , о чудо чудное и диво дивное, таки пошла анимация индикации прогресса загрузки установки  Windows 10 (х64) !!!!!
Победа!!!!
Ну дальше все было, в основном, по схеме. Установка началась, и я дошел до выбора диска для установки, но, как ни странно, Винда не выдала ошибку типа того, что ее установка невозможна так как диск имеет стиль разделов MBR и т.п. (а он таки имел такой). Просто диск «С:» (он же диск «0») был неактивен для манипуляций с ним, как и другие видимые диски. Но это все уже ерунда. Тут все понятно и тривиально – конвертировать жесткий диск из MBR в GPT самостоятельно прямо в процессе установки Винды, т.к. UEFI работает только с дисками со стилем разделов GPT (!).
При помощи командной строки самой Винды, вызванной магическим заклинанием использовав сочетании секретных клавиш (shift + f10), и самого заклинания – «diskpart», с последующим применением команд: «diskpart», «list disk», «select disk 0», «clean» и «convert gpt» и так далее в отношении диска «0», он же «С:», он же NVMe SSD М2 Gen 4.0 Samsung 980 PRO 250 GB (MZ-V8P250BW), был изменен стиль разделов последнего с MBR  на GPT, ну и ВСЕ, дальше выбор нужного диска для установки и Happy End!!!
Винда в режиме «boot mode select – UEFI» установлена!!!! 
Вот как-то так!!!!
Записан

st-sled

  • Сержант
  • ****
  • Reputation Power: 20
  • st-sled пока не имеет никакого влияния.
  • Оффлайн Оффлайн
  • Сообщений: 18

Да, забыл, еще можно было попробовать установить все с DVD привода, то есть загрузится с оптического диска создав его отдельно, ну это был у меня последний вариант и я до него не дошел, но я думаю, сработало бы  наверно, но пробовать пока не буду )))))
Записан